What do I need to use the platform?

To use the edloomio LMS, you need a modern browser and an active internet connection.

Edloomio works with all modern browsers but we advice Google Chrome for the best experience.

Still need help? Contact Us Contact Us